4Trabes Historias de una empresa en 100 metros cuadrados

El blog de Trabe Soluciones

Java 1.6 en Mac OS X

| | Comentarios

Para los incrédulos…

Java 1.6 en Mac OS X


Lo sentimos, pero los comentarios están cerrados

Pues es verdad, estar está.

27/Apr/2009 Adrian

Buenas!,
yo estoy en 10.5.5, penúltima versión de Mac OS X Leopard, versión estándar de 32 bits, no Server. Con lo que viene por defecto instalado tengo esto:

$ uname -a

Darwin javis-mac-pro.local 9.5.0 Darwin Kernel Version 9.5.0: Wed Sep 3 11:29:43 PDT 2008; root:xnu-1228.7.58~1/RELEASE_I386 i386

$ java -version

java version “1.5.0_16”
Java™ 2 Runtime Environment, Standard Edition (build 1.5.0_16-b06-284)
Java HotSpot™ Client VM (build 1.5.0_16-133, mixed mode, sharing)


Desconozco si con la 10.5.6 esto cambia, aunque lo dudo.

Barral, ¿ estás hablando de la versión Mac OS X Server o de la versión estándar ? Lo digo, porque la estándar es de 32 bits y ellos sólo han lanzado Java 1.6 para 64 bits (si no me equivoco).

Saludos.

28/Apr/2009 JRodas

Puedes mirar en /System/Library/Frameworks/JavaVM.framework/Versions/ a ver que hay :)

Tengo entendido que, efectivamente es sólo para 64 bits (Core 2 Duo o Xeon).

Si tienes una máquina de 32 bits puedes probar con SoyLatte (http://landonf.bikemonkey.org/static/soylatte), a ver que tal.

Buenas Barral,
tengo una máquina de 64 bits, Core 2 Quad, pero el kernel del sistema está compilado para 32 bits en la versión estandar de Leopard, como aparece al poner “uname -a”. Al menos es así en mi caso, no se en el tuyo, porque en la captura de pantalla que pones no aparece la parte derecha de esa línea donde pone la arquitectura del kernel.

He visto en el directorio de versiones de Java que comentas y efectivamente aparece la 1.6, pero la CurrentJDK apunta a la 1.5, y el Current apunta a A, que no se que significa.

07/May/2009 JRodas

el uname completo:
Darwin io.local 9.6.0 Darwin Kernel Version 9.6.0: Mon Nov 24 17:37:00 PST 2008; root:xnu-1228.9.59~1/RELEASE_I386 i386

A es una versión 1.5, aunque yo tampoco sé porqué se llama así xDDDDD

De todos modos, no te recomiendo cambiar los enlaces simbólicos. Algunas aplicaciones no lo llevan bien, en mi caso Netbeans y Open Office. Para usar la versión 6 métela en el PATH sin más :)

ninguna

22/Jun/2009 Raul Hernan